Avalanche powered by Wavelink

> Getting Started > Installing Avalanche > Avalanche Upgrade Process

Avalanche Upgrade Process

If you already have Avalanche servers installed, then you will want to perform an upgrade to preserve existing data.

The installer for Avalanche 6.1 migrates the profiles, users, and navigation tree; removes any Avalanche services that are installed locally; and installs the new version.

During migration, most of the data in the Enterprise Server database is copied to the 6.1 databases and then modified. If you install Avalanche 6.1 on a different computer than an existing version, you can continue to use Avalanche until all your devices are pointed to the new server. Device statistics, mobile device details, scheduled events, and report definitions are not copied to the 6.1 databases when upgrading from Avalanche 5.3.1, but are retained in the original databases.

Completed reports (in PDF, XML, or CSV format) are not migrated, but they are not deleted and can still be accessed through the file system.

When you install Avalanche 6.1 at a different location than your original server, software packages are not copied to the new environment and must be moved manually.

The following are supported versions able to upgrade to Avalanche 6.1:

Avalanche SE 5.3.0.572

Avalanche MC 5.3.0.543

Avalanche MC External DB 5.3.0.543

Avalanche MC 5.3.1.50

Avalanche MC External DB 5.3.1.50

Avalanche 6.0

If you have an earlier version than those listed above, you must first upgrade to Avalanche 5.3.1 before upgrading to 6.1.

When upgrading from Avalanche 5.3 to 6.1, Wavelink suggests the following methods for performing the upgrade:

Upgrading via a Cloned Environment (Recommended)

Upgrading through a New Install

When upgrading from Avalanche 6.0 to 6.1, you can perform the upgrade from your existing Enterprise Server location. However, Wavelink recommends that you back up all databases prior to any upgrades. For more information, see Upgrading from Avalanche 6.0 or Newer.

For a video tutorial of upgrading Avalanche using a cloned environment, see the video on Wavelink's YouTube page.

Upgrading Databases

During any Avalanche upgrades, your databases must be upgraded to the new Avalanche 6.0 and newer table structure. You need Windows SQL Server 2008, 2012, or 2014 to run Avalanche 6.0 and newer. When you begin the upgrade process, you must have the new database server installed to facilitate a successful upgrade.

Microsoft SQL Server Express is available for free commercial use, but comes with hardware limitations that govern the number of CPU cores, memory, and hard drive space that can be used per instance. Should an upgraded version be necessary to manage your databases, you are responsible for all licensing and fees associated.

Prior to upgrading Avalanche or your databases, we recommend you perform the following tasks:

Back up all Avalanche databases

Install Microsoft SQL Server 2008, 2012, or 2014 Express, Standard, or Enterprise edition.

Identify and keep record of all current scheduled tasks in Avalanche, as these will be lost during the upgrade process

Ensure no other users or tasks are using the database during the upgrade process

When upgrading from Avalanche 5.3 with an existing installation Microsoft SQL Server 2008, 2012, or 2014 on a machine not local to the enterprise server, the following tools must also be manually installed:

Microsoft SQL Server 2012 Native Client

Microsoft ODBC Driver 11 for SQL Server

Microsoft Command Line Utilities 11 for SQL Server

In some instances, you may need to verify the path to Microsoft Command Line Utilities. After installing, the sqlcmd.exe file should be located at C:\Program Files\Microsoft SQL Server\100\Tools\Binn\. To ensure connectivity from the computer you're installing Avalanche on, open a command prompt and type sqlcmd -S[Server Address] -U[Microsoft SQL Server User Login] -P[Login Password]. If a 1> appears, you will be able to connect to the database during the Avalanche upgrade. If not, additional troubleshooting is needed.


Was this article useful?    

The topic was:

Inaccurate

Incomplete

Not what I expected

Other